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Introducing TracerDAQ
TracerDAQ is a collection of four virtual instrument applications used to graphically display and store input data and 
generate output signals using Measurement Computing data acquisition hardware:

n Strip Chart - log and graph values acquired from analog inputs, digital inputs, temperature inputs, and counter inputs. 

n Oscilloscope - display values acquired from analog inputs 

n Function Generator - generate waveforms for analog outputs 

n Rate Generator - generate waveforms for counter outputs 

TracerDAQ provides many features that let you configure hardware, save measurement data and configuration information, 
and print displayed data. Refer to each application for specific features.

You can use TracerDAQ with Measurement Computing PCI Series, USB Series, WLS Series, and PC-CARD hardware. You 
can acquire and display data with TracerDAQ soon after you install your Measurement Computing DAQ hardware.

TracerDAQ vs TracerDAQ Pro

Two versions of TracerDAQ are available - TracerDAQ and TracerDAQ Pro.  

TracerDAQ Pro provides all of the features in TracerDAQ, plus additional options that are indicated in each topic. 

For a summary of the feature differences between the two versions, refer to the "Feature comparison between TracerDAQ
and TracerDAQ Pro" topic.

Using MCCDAQ hardware with TracerDAQ

Before starting TracerDAQ, you must configure your Measurement Computing data acquisition hardware with InstaCal. 
InstaCal stores all board-specific configuration information in a configuration file named CB.CFG. InstaCal creates and/or 
modifies this file when board configuration is added or updated. TracerDAQ reads the CB.CFG file to access the data 
acquisition board. Refer to the Quick Start Guide that was shipped with your Measurement Computing hardware for 
information about configuring your DAQ devices with InstaCal.

Running TracerDAQ 

Run TracerDAQ by selecting Programs ���� Measurement Computing ���� TracerDAQ ���� TracerDAQ from the Start 
menu. TracerDAQ is installed by default in the C:\Program Files\Measurement Computing\TracerDAQ directory.

When you launch TracerDAQ, the main TracerDAQ window opens. You run TracerDAQ's virtual applications from this 
window.

A description of the selected application appears on the window. Click the Run button to start the application selected.

n With TracerDAQ, you can run one instance of each application at a time.

n With TracerDAQ Pro, you can run multiple instances of each application at a time, as long as the applications use 
different Measurement Computing DAQ hardware.

Click on one of the links below for an overview of the features in each application.

n Strip Chart

n Oscilloscope

n Function Generator

n Rate Generator
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Each overview also provides a link to a Quick Start exercise you can perform that gets you up and running quickly with 
the application.

Note on measurement units: Measurements may display in a TracerDAQ application with the suffix m, u, or n. These 
units correspond to the following:
m = milli
u = micro
n = nano
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TracerDAQ® End User License Agreement
IMPORTANT - READ CAREFULLY 

This Measurement Computing Corporation End User License Agreement accompanies the TracerDAQ software product and 
related media, printed materials, and "on-line" or electronic documentation ("Software"). The term "Software" also shall 
include any upgrades, modified versions or updates of the Software licensed to you by Measurement Computing 
Corporation. After reading this Agreement, you will be asked to accept its terms and continue to install the Software or, if 
you do not wish to accept the Agreement, to decline its terms, in which case you may not install, use or copy the Software. 
By clicking on the "I accept the terms in the license agreement" button, installing, copying or otherwise using the Software, 
you agree to be bound by the terms of this Agreement. If you do not agree to the terms of this Agreement, click on the "I 
do not accept the terms in the license agreement" button and/or do not install the Software. You will be entitled to a full 
refund of the purchase price. 
The Software is owned by Measurement Computing Corporation. It is protected by copyright laws and international 
copyright treaties, as well as other intellectual property laws and treaties, including, without limitation patents and trade 
secrets. The Software is licensed, not sold. Upon acceptance of this Agreement, Measurement Computing Corporation 
grants to you a non- exclusive license to use the Software, provided that you agree to the following terms:  
1. Use. All title and copyrights in and to the Software are owned by Measurement Computing Corporation. Accordingly, 

you must treat the Software like any other copyrighted material, except that you may install and use one copy of the 
Software on a single computer, provided that you keep the original solely for back-up or archival purposes. Except as 
stated above, this Agreement does not grant you any intellectual property rights in the Software.

2. Limitations on Reverse Engineering, Decompilation, and Disassembly. You may not reverse engineer, 
decompile, disassemble, modify, translate or otherwise attempt to discover the source code of the Software.

3. Separation of Components. The Software is licensed as a single product. Its component parts may not be separated 
for use on more than one computer.

4. Rental. You may not rent, lease, or lend the Software.
5. Transfer. You may not transfer your license to another party.
6. Civil and professional communications. You agree to communicate with Measurement Computing Corporation and 

its employees in a civil and professional manner in all matters relating to the support or use of TracerDAQ. Use of 
abusive or profane language in written or oral communication will result in the cancellation of your license.

7. Export. You agree that the Software will not be shipped, transferred or exported into any country or used in any 
manner prohibited by the United States Export Administration Act or any other export laws, restrictions or regulations.

8. Disclaimer of Warranty. The Software is being delivered to you "AS IS" and Measurement Computing Corporation 
makes no warranty, express or implied, of any kind, including, without limitation, as to its use or performance. Good 
programming procedure dictates that any application program be thoroughly tested with non-critical data before being 
relied upon. The entire risk arising out of the use or performance of the Software remains with you.
TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MEASUREMENT COMPUTING CORPORATION AND ITS 
SUPPLIERS DO NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULTS YOU MAY OBTAIN BY USING THE 
SOFTWARE. MEASUREMENT COMPUTING CORPORATION AND ITS SUPPLIERS MAKE NO WARRANTIES, EXPRESS OR 
IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY IMPLIED WARRANTIES AS TO NON-INFRINGEMENT OF THIRD PARTY 
RIGHTS, MERCHANTABILITY, OR FITNESS FOR ANY PARTICULAR PURPOSE.

9. Limitation of Remedies. Measurement Computing Corporation and its suppliers’ entire liability and your exclusive 
remedy shall be, at Measurement Computing Corporation's option, either (a) return of the price paid, if any, or (b) 
repair or replacement of the Software.
TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL MEASUREMENT COMPUTING 
CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DIRECT, SPECIAL, INCIDENTAL, INDIRECT, PUNITIVE, OR 
CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS 
PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING 
OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE OR THE PROVISION OF OR FAILURE TO PROVIDE SUPPORT 
SERVICES, EVEN IF MEASUREMENT COMPUTING CORPORATION HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES.
Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or 
the exclusion of implied warranties or limitations on how long an implied warranty may last, so the above limitations 
may not apply to you.

10. Indemnification. You agree to use, build, create or develop only those program elements, including without limitation 
objects or controls, for which you have the necessary patent, copyright and other permissions, licenses, and/or 
clearances. You agree to hold harmless, indemnify and defend Measurement Computing Corporation, its officers, 
directors and employees, from and against any losses, damages, fines and expenses (including attorneys’ fees and 
costs) arising out of or relating to any claims or charges that you have used, built, created or developed any program 
elements in connection with the Software in violation of another party’s rights or in violation of any law. 

11. Termination. This Agreement shall automatically terminate upon failure by you to comply with its terms. Upon 
termination, you must destroy all copies of the Software.

12. Other. This Agreement shall constitute the complete and exclusive agreement between us. This Agreement shall be 
governed by the laws of the Commonwealth of Massachusetts, and you hereby consent to the exclusive jurisdiction of 
the state and federal courts sitting in the Commonwealth of Massachusetts. This Agreement may only be modified in a 
separate writing signed by an authorized officer of Measurement Computing Corporation. If any part of this Agreement 
is found void or unenforceable, it will not affect the validity of the other terms of the Agreement, which shall remain 
valid and enforceable.

YOUR ACCEPTANCE OF THE FOREGOING AGREEMENT WAS INDICATED DURING INSTALLATION.
Copyright© 2007 Measurement Computing Corporation, Norton, Massachusetts
TracerDAQ is a registered trademark of Measurement Computing Corporation.
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Platform requirements and recommendations

Required software

You can run TracerDAQ on a computer running one of the following operating systems and software.

n Microsoft® Windows 2000 (SP4), Windows XP (SP2), Windows Vista
 

n Microsoft .NET® Framework 2.0
 

n DirectX 9.0c

n Measurement Computing's InstaCal

The TracerDAQ installation automatically installs the Microsoft .NET® Framework 2.0 if this application is not already 
installed.

The TracerDAQ installation always installs DirectX 9.0c even if the software is already installed.

PC-CARD hardware is not supported under Windows Vista.

System requirements

n Video card with 16 MB of memory and Direct3D Acceleration (see the note below)

n Minimum screen resolution of 1024 x 768

n Computer with Pentium® 4 processor and 256 MB of RAM
 

n A Microsoft-compatible mouse

Note: To verify that Direct 3D is installed and enabled on your computer, do the following:

1. From the Start button, select Run and enter Dxdiag in the text box of the Run dialog.
2. Click OK. The DirectX Diagnostic Tool dialog opens.
3. Click on the Display tab.
4. Within the DirectX Features pane, verify that the Direct3D Acceleration status is Enabled.

If the status is Disabled, click the associated Enable button next to the status to enable this feature. 
If the status is Not Available, you will be unable to run TracerDAQ. Upgrade your video card to one that supports 
Direct3D Acceleration. 

Supported Measurement Computing data acquisition hardware

n PCI Series, USB Series, WLS Series, and PC-CARD devices 

n InstaCal's DEMO-BOARD, a software-based data acquisition board that simulates analog input and digital I/O operations.  

Specific hardware requirements for each virtual application are listed below:

Strip chart

n Analog inputs

n Digital inputs

n Temperature inputs

n Event counters

n PCI-CTR Series 

n USB-4300 Series 

n PCI-2500 Series and USB-2500 Series counters 

Oscilloscope

n Analog inputs

Function Generator

n Analog outputs

Rate Generator

n PCI-CTR Series 

n USB-4300 Series 

n PCI-2500 Series and USB-2500 Series timers 
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How to use this help file
This online help file uses the following conventions:

 

Convention Explanation

Blue underlined text Text popup or hyperlink. 
n Clicking on blue underlined text either links to another topic in the help file, or shows 

additional information in a text-only "popup" window. 

Green underlined text Drop-down text used to show images. 
n Click once on green text to show an image in a drop-down window. Click again to hide the 

drop down window. 
For example, "The DAQ Hardware Settings dialog opens."

TracerDAQ Pro information.
This icon appears in the Table of Contents with topics that provide information specific to 
TracerDAQ Pro.

Information that is applicable to either TracerDAQ or TracerDAQ Pro is indicated in each help 
topic. 
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Feature comparison between TracerDAQ and TracerDAQ Pro
Two versions of TracerDAQ are available - TracerDAQ and TracerDAQ Pro. 

With TracerDAQ, you can run one instance of each application at a time. With TracerDAQ Pro, you can run multiple 
instances of each application at a time, as long as the applications use different DAQ hardware resources.

The following tables summarize the features provided in TracerDAQ and TracerDAQ Pro for each virtual application.

Strip Chart

 

Oscilloscope

 

 

 

 

Feature TracerDAQ TracerDAQ Pro

Channel types supported Analog input, temperature input, 
digital input, event counter

Analog input, temperature input, digital 
input, event counter

Number of channels Up to 8 Up to 48

Number of lanes (individually 
scaleable)

2 8

Maximum sampling rate Maximum "continuous" acquisition 
rate of the device

Maximum "continuous"acquisition rate 
of the device

Maximum samples per channel 32,000 samples 1 million samples

Print/preview strip chart Yes Yes

Capture a strip chart image to the 
clipboard

No Yes

Save as a history file (*.sch) or 
text file (*.txt or *.csv)

Yes Yes

Open a history file (*.sch), binary 
file (*.bin), or ASCII text file (*.txt 
or *.csv)

Yes Yes

Save configurations Yes Yes

Alarm conditions No Yes

Strip Chart Measurements window No Yes

Enter annotations No Yes

Software triggering No Yes

Hardware triggering No Yes

Time-of-day triggering No Yes

Linear scaling No Yes

Feature TracerDAQ TracerDAQ Pro

Channel type supported Analog input Analog input

Number of channels Up to 2 Up to 4

Maximum sample rate Maximum "continuous" acquisition 
rate of the device

Maximum "continuous" acquisition rate 
of the device

Print/preview oscilloscope Yes Yes

Capture an oscilloscope image to 
the clipboard

No Yes

Auto trigger Yes Yes
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Function Generator

 

Rate Generator

   

  
 

 
 

   

 
  

  

  
 

 
 

   

   

 
 

  

   
   

  

   
   
 

  

   

   

   

   

   

   

        

   

   

   

   

  
 

 
 

   

 
 

  

   

Channel triggering (level and 
position)

Yes Yes

Horizontal markers Yes Yes

Vertical markers Yes Yes

Save configurations Yes Yes

Load configurations Yes Yes

Save as a history file (*.osh), or 
ASCII text file (*.txt or *.csv)

Yes Yes

Open a history file (*.osh) Yes Yes

Oscilloscope Measurements 
window

No Yes

Reference channel No Yes

Math channel No Yes

Feature TracerDAQ TracerDAQ Pro

Channel type supported Analog output Analog output

Number of channels 1 Up to 16

Maximum sample rate Based on the maximum "continuous" 
rate of the device (see "Introducing
the function generator" for full 
explanation)

Based on the maximum "continuous" 
rate of the device (see "Introducing the
function generator" for full explanation)

Waveform types Sine Sine, Square, Triangle, Flat, Pulse, 
Ramp, Random, and Arbitrary* 
* Generated from data stored in a .csv 
or .txt file.

Waveform preview Yes Yes

Amplitude Yes Yes

Frequency Yes Yes

DC offset Yes Yes

Duty cycle No Yes

Phase No Yes

Gate ratio No Yes

Rate multiplier No Yes

Sweep (linear and exponential) No Yes

Open .csv or .txt file (arbitrary 
waveform)

No Yes

Save configurations Yes Yes

Load configurations Yes Yes

Feature TracerDAQ TracerDAQ Pro
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Channel type supported Counter output Counter output

Counter types supported n 9513-based counters 
n Timer output counters (USB-2500 

and PCI-2500 Series devices) 

n 9513-based counters 
n Timer output counters (USB-2500 

and PCI-2500 Series devices) 

Number of channels 1 Up to 20

Pattern types supported Continuous pulse Continuous pulse

Save configurations Yes Yes

Load configurations Yes Yes
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Introducing the strip chart
TracerDAQ's strip chart is a virtual graphing and data logging application used to acquire data from Measurement 
Computing DAQ devices that support analog input, temperature input, digital input and/or counter inputs. The strip chart 
supports the maximum speed of Measurement Computing DAQ hardware.

With the strip chart, you can perform the following tasks:

n Plot up to 48 channels of data acquired from one or more Measurement Computing DAQ devices with TracerDAQ Pro. 

Plot up to eight channels of data acquired with TracerDAQ.

n Display specific measurement values for each channel (TracerDAQ Pro only)

n Trigger the acquisition using an internal software trigger, external hardware trigger, or a timed interval trigger 
(TracerDAQ Pro only).

n Set up alarm conditions for each channel (TracerDAQ Pro only).

n Scale channel data.

n Change the timebase to view more or less data on the plot.

n Add comments (annotations) to the display plot.

n Save data as a history file (.sch) or text file (.txt or .csv).

n Import and plot binary (.bin) and text data (.csv and .txt).

n Isolate specific data for analysis.

n Play back an acquisition.

n Store hardware configurations for future use.

n Customize the appearance of the strip chart.

Hotspots on the strip chart let you change settings while the strip chart is running. 

Strip chart dialogs feature tool tips that explain the function of each option. 

A status bar on the strip chart lets you know the operation status, when an option setting is invalid, or if an error condition 
occurs.

Data is plotted on the strip chart in individually scaleable lanes. TracerDAQ Pro supports eight lanes, and TracerDAQ 
supports two lanes. You can select the lane number where you want to plot data. Multiple channels can be plotted in each 
lane.

Two moveable data point markers let you view data at specific locations on the strip chart. The value of channel data at 
each marker position appears in a separate window.

Error conditions are automatically logged in the strip chart’s Annotation dialog. 

Strip chart quick start

For a quick, hands-on exercise that shows you how to acquire and display data using the strip chart, click on the Quick Start 
button below.

This quick start exercise shows you how to acquire and plot data from Measurement Computing's DEMO-BOARD virtual data 
acquisition hardware. No additional hardware is required.
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Overview of the strip chart environment
When you run the strip chart, the Strip Chart window, the Strip Chart Measurements window (TracerDAQ Pro only), and 
the Strip Chart Markers window open by default, as shown here:

n The Strip Chart window plots the acquired data. Hotspots let you configure data and display settings right on the window.

n The Strip Chart Measurements window shows specific measurement values for each channel configured to acquire data.

n The Strip Chart Markers window shows the values of channel data at each marker, and also the amplitude difference 
between the markers for each channel.

Components on the Strip Chart window

Components on the Strip Chart window are identified below. Place your cursor over a component name to display a brief 
description. 

An asterisk (*) after the name indicates that the component is also a hotspot. For more information about strip chart hotspots, 
go to the Hotspots on the strip chart topic.
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How the strip chart acquires data

The strip chart supports the maximum speed of Measurement Computing DAQ hardware. When acquiring data from hardware 
channels that support paced I/O, the strip chart uses a scan function to acquire the data. If the channels do not support paced 
I/O, then single-point I/O is used to acquire data on those channels.  

When a device includes channels that support both paced I/O and channels that do not, the single-point I/O channels use a 
"current value" that is updated as fast as possible through the single-point I/O function calls. The strip chart reads the current 
values on these channels for each data point it reads from the scan buffer used for the paced I/O channels. The strip chart may 
read the same "current value" from a channel multiple times before it is updated. In this way, all channels on the strip chart 
have the same number of data points in their plots.

The display update time varies from device to device, and may take longer than the acquisition time to acquire the data.

Concurrent scanning of analog, digital, and counter inputs

When acquiring data from hardware that supports concurrent scanning of analog, digital, and counter inputs, such as the USB-
2500 Series hardware, timing is based on hardware timed I/O, and is not system dependent.

When acquiring data from hardware that dos not support concurrent scanning, timing is based on single-point I/O using the 
system timer, and is system dependent.

Error handling

Under most error conditions, the strip chart pauses the acquisition, and displays an error message in the acquisition status bar 
and in a message box. Click here for an example.

There are a few error conditions in which the strip chart attempts to restart after it pauses the acquisition: 

n DATA_OVERRUN (Universal Library error code 29)

n NO_REMOTE_ACK (Universal Library error code 186)

n INPUT_TIMEOUT (Universal Library error code 187)

For these errors, the status bar displays the error condition, and indicates that the strip chart is waiting to restart.  

If the error condition is OPEN_THREMOCOUPLE (Universal Library error code 145), the strip chart indicates the error condition 
in the status bar, but does not pause the acquisition.

All error conditions are automatically logged in the strip chart’s Annotation dialog. For more information, go to the "Entering 
or viewing annotations on the strip chart" topic.
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Overview of the strip chart menu bar
The strip chart menu bar options are explained in the following table.

 

Menu item Explanation

File Includes options you can use to:
n save, open, and close strip chart history files (.sch) and text files (.csv or .txt)
n Open and plot binary files (*.bin)
n save or load a configuration file
n preview and print screen captures of strip chart data
n set up strip chart preference settings

Click on the following button for instructions on how to perform these tasks. 

Edit Includes options you can use to:
n configure Measurement Computing data acquisition hardware
n scale strip chart data
n set the timebase value
n set up strip chart channels, markers, and display settings
n clear data from the strip chart
n copy an image of the strip chart to the clipboard (TracerDAQ Pro only)
n set up trigger options (TracerDAQ Pro only)
n set up alarm options (TracerDAQ Pro only)

Most Edit menu items are disabled when the strip chart is running or paused. You cannot 
change hardware, channels or display settings during an acquisition.

Click on the following button for instructions on how to perform these tasks. 

View Includes options you can use to:
n show/hide the Strip Chart Markers window (displays marker values)
n show/hide the Strip Chart Measurements window (displays specific channel 

measurements)
n show/hide user-entered annotations on the strip chart display 
n enable/disable pop up tool tips on strip chart dialogs

Action Includes options you can use to:
n run, pause, or stop acquiring data
n start, pause, or stop playing back scan data (go to "Playing back scan data on the strip

chart" for instructions on playing back data.)  

Help Includes options you can use to:
n open the TracerDAQ online help file
n view TracerDAQ version and contact information
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Hotspots on the strip chart
The Strip Chart window has several hotspots. A hotspot is an interactive area on the strip chart that lets you change 
settings while the strip chart is running. All hotspots have corresponding dialogs that you access through the strip chart 
menu bar to perform the same action.

You can enable and disable hotspots using the Display Settings dialog (Display Settings option on the Edit menu). 
Hotspots are enabled when the "Enable hotspot" check box is checked.

The following hotspots are available on the strip chart.

 

Hotspot Explanation

DAQ controls RunRunRunRun: Starts acquiring data from the configured hardware devices. 

n Begins logging data to a file, if logging is enabled.
n Begins monitoring for trigger conditions, if a condition is specified (TracerDAQ Pro 

only).
n This hotspot is disabled while the strip chart is running, and enabled when the 

Pause or Stop hotspots are clicked.

PausePausePausePause: Pauses data acquisition. The strip chart continues acquiring data, but the 
data is not plotted on the display. 

n Suspends data logging, if logging is enabled.
n This hotspot is disabled when acquisition is paused, and enabled when the Start 

hotspot is clicked again.

StopStopStopStop: Stops data acquisition and display.

n Stops data logging, if logging is enabled.
n This hotspot is disabled when the strip chart is stopped, and enabled when the 

strip chart is running or paused.

PLYPLYPLYPLY : Toggles playback mode on and off. 

SETSETSETSET : Opens a dialog for setting display, channel, and marker properties. 

Sets the value per major horizontal division. There are ten major horizontal 
divisions. Click the up/down arrows to change the value.

n You can set the timebase to 1µS, 2µS, 5µS, 10µS, 20µS, 50µS, 100µS, 200µS, 
500µS, 1mS, 2mS, 5mS, 10ms, 20mS, 50mS, 100mS, 200mS, 500ms, 1s, 2s, 5s, 
10s, 20s, 50s, 100s, 200s, 500s, 1000s, 1hr, 2hr, 5hr, 10hr, 20hr, 1day, 2 days, 5 
days, 10 days, 20 days, 50 days, or 100 days.

n If your computer mouse has a wheel, you can roll forward to increase the 
timebase value, and roll backward to decrease the timebase.

n Hold down the Shift key to change the timebase setting in multiples of 10. For 
example, when you change the timebase while holding down the Shift key, the 
value changes from 1.00s to 10.0s, 100s, 1000s, etc.

Auto mode:

n The timebase may also be set to AutoAutoAutoAuto mode by clicking on the AAAA   hotspot next to 
the up/down arrows. When enabled, the timebase value setting automatically 
increases when the strip chart acquires enough data to fill 50% of the screen for 
the next timebase setting scale. This is done in order to display all data points.

For more information on timebase controls, go to the Using strip chart timebase
controls topic.

Scale mode
 

 Fixed
 

  Auto
 

  NonOverlapped
 

Sets the scale mode for that lane. There are three scaling modes: Fixed, Auto and 
NonOverlapped. Clicking on the Scale Mode hotspot sequences through each mode.
n FixedFixedFixedFixed: The strip chart scales the data to the Upper and Lower limits set for the 

lane. In this mode, you can edit the range limits - click on the Upper Limit 
hotspot and Lower Limit hotspot to display a text box, and enter a new value.

n AutoAutoAutoAuto: The strip chart calculates a scale that best fits the data. In this mode, the 
Upper and Lower Limits are not editable.

n NonOverlappedNonOverlappedNonOverlappedNonOverlapped: The strip chart evenly scales all channels in a particular lane in 
magnitude and spacing so they do not overlap. In this mode, the upper and lower 
limits are not displayed. This mode is particularly useful for displaying digital 
inputs in the same lane.
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Playback controls Playback StartPlayback StartPlayback StartPlayback Start: Starts playing back data that has just been acquired or loaded 
from a previously saved file.

n When data acquisition has just been completed or a history file has been loaded, 
this is considered “playback” mode. 

n This hotspot is disabled while the strip chart is playing back data.

Playback PausePlayback PausePlayback PausePlayback Pause: Pauses playback of data.

n This hotspot is disabled while data playback is paused.

Playback StopPlayback StopPlayback StopPlayback Stop: Stops playing back data.
n This hotspot is disabled when data playback is stopped.

 (Playback speed) Increments or decrements the speed at which data is played back. Click on the plus 
or minus button to multiply the original data rate by the following values:
0.001, 0.01, 0.1, 1.0, 10, 100, 1000

n Click "+" to increment the speed, or "-" to decrement the playback speed. 

Playback scroll bar

Scrolls the data in playback mode toward the beginning or end of the acquisition.

n Scrolling left moves the data plot towards the start of the acquisition.
n Scrolling right moves the data plot towards the end of the scan.

You can also scroll data with the left and right arrow keys on the computer:

n Pressing the left arrow key moves data plot towards the start of the acquisition.
n Pressing the right arrow key moves data plot towards the end of the scan.

Tip: Hold down the Shift key while pressing the arrow key to increase the 
scrolling speed.

Acquisition progress bar: When the strip chart is not in playback mode, this scroll 
bar shows the progress of the current scan.

Markers The strip chart has two moveable markers used to view data at specific locations on 
the strip chart.

Scroll the markers from left to right to show the value of the data point at each 
marker's position in the upper left corner of the strip chart. 

The delta position (the time between the two markers) shows next to the Timebase 
hotspot controls in the upper right corner of the strip chart.

Marker values also appear in the Strip Chart Markers window, if visible. You can 
turn this window on and off with the View > Marker Values menu.

EEEE  (Edit mode) The EEEE  edit hotspot appears on the strip chart when you open a history (*.sch) file. 
Click on the EEEE  hotspot to toggle between ReviewOnly mode and Edit&Save mode. 

n Review Only mode: changes to the history file cannot be saved. The File > Save 
option is disabled. You can save changes to a different file name using the File > 
Save As option. This mode appears on the strip chart as: 

n Edit&Save mode: changes to the history file are automatically saved. This mode 
appears on the strip chart as:
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Quick Start - Plotting DEMO-BOARD signals with the strip chart 
As stated in the introduction, you can acquire and display data with TracerDAQ "soon after you install your Measurement 
Computing DAQ hardware."
You can get a feel for what TracerDAQ can do even sooner by trying it out with the DEMO-BOARD, which is a simulated ISA 
board included with InstaCal.
To acquire and plot DEMO-BOARD signals on the strip chart:
1. Make sure you have completed the steps in the "Running InstaCal and adding your hardware" section of the DAQ 

Software Quick Start.
2. Run TracerDAQ by selecting Programs ���� Measurement Computing ���� TracerDAQ ���� TracerDAQ from the Start 

menu.
3. From the TracerDAQ dialog, select Strip Chart, and click on Run. The strip chart application opens.
4. Select New... from the File menu. The DAQ Hardware Settings dialog opens.
5. From the first row of the DAQ Device column, select the DEMO-BOARD from the list-box. Click here for an example.

The drop-down list shows the device ID and device name for all boards that are configured by InstaCal. When you 
select a device, the first channel and range supported by the device appear in the DAQ Channel and DAQ 
Range/Mode columns.

6. Right-mouse click on the first column, and select AutoFill All from the popup menu. The dialog automatically becomes 
configured to acquire data from four channels on the DEMO-BOARD.
Click here to see the dialog configured to acquire data from four channels on the DEMO-BOARD

7. Click on the OK button to save the settings and close the dialog.
8. From the Edit menu, select Scan Rate/Trigger Settings…. The Scan Rate/Trigger Settings dialog opens. 
9. Change the Acquire data for settings so that the scan runs for 5 seconds.

Click here to see the dialog configured to acquire data for 5 seconds.
10. To view plots that don't overlap, click on the scale mode hotspot ( ) on the left side of the strip chart window until it 

turns to  (non-overlap mode).
11. Click on the OK button to save the settings and close the dialog.
12. Click the Run button ( ) on the strip chart.

The strip chart acquires and displays data from the first four channels (0 - 3) of the DEMO-BOARD. 

 

That's all there is to it! The strip chart provides many options for working with strip chart data and customizing the strip 
chart display. Refer to the topics in the Table of Contents for more information.
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Configuring DAQ hardware for the strip chart
You can acquire data from Measurement Computing data acquisition hardware that supports analog input, temperature 
input, digital input and/or counter inputs.

You set up your hardware configuration with the DAQ Hardware Settings dialog. Use this dialog to configure the 
hardware, channels, and range used to acquire data. You can also use this dialog to filter specific input types, and set up 
options for external hardware digital triggering.

The first time you run the strip chart, the dialog opens without any configuration information. Dialog tool tips advise you of 
the action to take.

You must stop the strip chart must be stopped for you to configure DAQ hardware. You cannot configure hardware when the 
strip chart is running or paused.

DAQ hardware settings

To configure your DAQ hardware:

1. Stop the strip chart if it is running.
2. Select DAQ Hardware Settings from the Edit menu (or select File > New). The DAQ Hardware Settings dialog 

opens.
3. By default, the dialog opens by default with four channels to configure. To change the number of channels, right-click in 

the first column and select Number of Channels. Enter the desired number of channels in the dialog that opens, and 
click OK.

4. In the DAQ Device column, select a hardware device from the drop-down list.
The drop-down list shows all boards that are configured by InstaCal. The list includes a device ID and a board name. 
The device ID is the board number assigned by InstaCal. For example, the device ID "Dev0" indicates board number 0.
When you select a device, the first channel and range supported by the device appear in the DAQ Channel and DAQ 
Range/Mode columns.

5. Review the channel listed in the DAQ Channel column. If the hardware supports additional channels, you can select a 
different channel number from the drop-down list.
You can specify which input types to list in the DAQ Channel column using the DAQ Selection Filter list box.

6. Review the range listed in the DAQ Range/Mode column. If the hardware supports additional ranges, you can select a 
different range from the drop-down list.
You can quickly configure the remaining channels to acquire data from the same hardware by using the context menu: 
Right-click in the first column of the first row and select AutoFill All. The hardware, channels, and range information 
populate the rows for the remaining channels.

7. If you want to externally trigger the acquisition, click on the HW Trigger tab.

¡ In the Trig Device column, select the hardware to use as the trigger source. The drop-down list shows all 
Measurement Computing hardware that you can use to trigger the acquisition.

¡ In the Trig Source column, select the signal to use as the trigger source. The drop-down list shows the signals on 
the hardware that can be used use to trigger the acquisition, such as TRIGIN or AUXIN0.

¡ In the Trig Edge column, select the edge to trigger on. Choices are Positive and Negative.

8. Click OK when you are done configuring your hardware. 
The OK button is disabled if the dialog contains invalid entries. 

Note: By default, the previous hardware configuration is loaded each time you open the dialog or launch the strip chart. To 
open the dialog without a hardware configuration, uncheck the Load last configuration option on the Strip Chart
Preferences dialog.

Context menu

You can right-click in the first column (Channeln) of the DAQ Hardware Settings dialog to display a context menu. Use the 
options on this menu to change the number of channels, configure or clear selected rows automatically, undo the last action, 
and redo the last action (when the last action was undone).
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C lick here for an explanation of the options on this menu.
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Saving a strip chart configuration file
You can save the strip chart hardware settings and display settings to a configuration file (*.scc). The file is saved in binary 
format in the location specified by the Configuration file path option in the Strip Chart Preferences dialog.

You can select from a list of pre-defined names, or enter a custom name for the configuration file. You can load each 
configuration file you save to restore the hardware and display settings on the strip chart.

To save current strip chart hardware and display settings to a configuration file:

1. Select Save Configuration from the File menu. The following menu options open.

2. Click on one of the pre-defined file names (User0 to User7) with which to save the file, or select Named 
Configuration to enter another name.
If you select one of the pre-defined options (UserN), the configuration information is automatically saved to a file with 
that name (UserN.scc).
If you select the Named Configuration option, a Save As dialog opens. Enter a name for the file (and change the 
location if you want), and then click Save to save the configuration file.

You can update the configuration file with any changes you make to the hardware settings or display settings by saving the 
configuration again with the same file name.

For information on loading a saved configuration file on the strip chart, go to Loading a strip chart configuration file.
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Loading a strip chart configuration file
You can load a strip chart configuration file (*.scc), and apply the settings to the current strip chart session.

When loaded, the hardware settings and display settings that are stored in the configuration file are applied to the strip 
chart. The name of the configuration file that you load is shown in the title bar of the strip chart. 

Configuration files are stored in the location specified by the Configuration file path property in the Strip Chart
Preferences dialog.

To load a configuration file:

1. Select Load Configuration from the File menu. The following menu options open.

2. If the configuration file was saved using one of the predefined names (User0 to User7), you can select one of these 
from the menu.
Or, click on Named Configuration to select a configuration file from an Open dialog.

The strip chart updates with the hardware and display settings that are stored in the configuration file. The name of the 
configuration file appears in the title bar of the strip chart.

For information on saving a configuration file, go to Saving a strip chart configuration file.
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Setting strip chart preferences
You can set various "preference" options that specify

n where the strip chart stores data and configuration files

n what configuration is loaded when you run the strip chart

n whether other strip chart windows automatically open when you run the strip chart, and how those windows behave in 
respect to the Strip Chart window 

n whether or not annotations are displayed on the strip chart

n whether or not logging and dialog tool tips are enabled 

n what measurement values to show on the Strip Chart Measurements window.

You can set strip chart preferences by selecting Preferences... from the File menu to open the Strip Chart Preferences 
dialog. The dialog is shown here configured with the default settings for TracerDAQ Pro.

If you are running TracerDAQ, the following options are disabled on this dialog:

n Display annotations check box

n Measurements check box

n Maximum, Minimum, Mean, and Current Value check boxes.

The start up options are stored in the system registry in HKEY_CURRENT_USER\Software\Measurement 
Computing\TracerDAQ\Preferences\StripChart.

 

Menu item Description

Configuration file 
path

Sets the directory to store configuration files (*.scc). The default path is:

n Windows 2000 and Windows XP: C:\Documents and Settings\<User 
Name>\Application Data\Measurement Computing\TracerDaq\Config

n Windows Vista: C:\ProgramData\Measurement Computing\TracerDaq\Config

Click the Browse button to select a different location.

Data file path Sets the directory used to store strip chart history files (*.sch). 

n Windows 2000 and Windows XP: C:\Documents and Settings\<User 
Name>\Application Data\Measurement Computing\TracerDaq\Data

n Windows Vista: C:\ProgramData\Measurement Computing\TracerDaq\Data

Click the Browse button to select a different location.

  
   

    
 

     
  

   

 
 

 

    
   

 
     

 
 

 
 

    
  
 

      
   

   
    
    

  

 
    

  

     

  
 

   
 

 
    

  
 

  

   
 

  
   

  
 

  
  

  
 

  
  

  
 

  
  

  
 

  
  

Page 20 of 106



 
 

  

  

  
   

  

  

    

       
 

 

   

   

         

   
 

  

  

 
 

   

   
     

      

   

    

   
    

      

   

Data logger file path Sets the directory used to store logger data files.
n For Windows 2000 and Windows XP, the default path is C:\Documents and 

Settings\<User Name>\Application Data\Measurement Computing\TracerDaq\Data 
Logger

n For Windows Vista, the default path is C:\ProgramData\Measurement 
Computing\TracerDaq\Data Logger

Click the Browse button to select a different location.

Data precision in CSV 
files

Sets the digits of precision applied to csv data.

Enable logging When checked, acquired data is automatically saved as a history file (*.sch) to the 
location set by the Data file path option (listed above).

When unchecked (default), data is not automatically saved to a history file. You can 
save data manually using the Save and Save As options on the File menu. 

Load last 
configuration

When checked, the strip chart opens with the hardware configuration that was used 
when you last closed the strip chart.

When Load last configuration is not checked, the settings on the Strip Chart 
Preferences dialog are applied to the strip chart the next time you run the 
application.

Move related views When checked, the Strip Chart Markers window and Strip Chart Measurements 
window (TracerDAQ Pro only) dock to the Strip Chart window. 

When you move the Strip Chart window, the other two windows move with it. 
However, you can move the Strip Chart Markers window and Strip Chart 
Measurements window independently of the Strip Chart window.

Display annotations When checked, annotations appear on the strip chart of each lane.

You can toggle annotations on and off during a scan session by selecting 
Annotations from the View menu.

Show tool tips When checked, tool tips are enabled on strip chart dialogs.

You can toggle tool tips on and off by selecting Tool Tips from the View menu.

Measurements 
(TracerDAQ Pro only)

When checked, the Strip Chart Measurements window automatically opens when 
you run the strip chart.

You can toggle this window on and off during a scan session by selecting 
Measurements from the View menu.

Markers (TracerDAQ 
Pro only)

Note: This check box is enabled in TracerDAQ Pro only.

When checked, the Strip Chart Markers window automatically opens when you run 
the strip chart.

You can toggle this window on and off during a scan session by selecting Markers 
from the View menu.

Maximum (TracerDAQ 
Pro only)

When checked, the maximum value of each enabled channel shows on the Strip 
Chart Measurements window.

Minimum (TracerDAQ 
Pro only)

When checked, the minimum value of each enabled channel shows on the Strip 
Chart Measurements window.

Mean (TracerDAQ Pro 
only)

When checked, the mean value of each enabled channel shows on the Strip Chart 
Measurements window.

Current Value 
(TracerDAQ Pro only)

When checked, the current value of each enabled channel shows on the Strip Chart 
Measurements window.

Page 21 of 106



Using strip chart timebase controls
You can change the timebase value when acquiring or viewing data on the strip chart. The timebase is represented on the 
strip chart by each major horizontal division. There are ten major horizontal divisions. 
Timebase settings range from 1 µS to 100 days.
The current timebase setting appears in the upper right corner of the strip chart, next to the timebase hotspot controls. 
The following example shows data plotted with a timebase of 100ms:

n Increase the timebase to show more data points on the strip chart. The following example shows the data plotted with a 
timebase of 500ms.

n Decrease the timebase to show fewer data points on the display. The following example shows the data plotted with a 
timebase of 50.0ms.

Using hotspot controls to change the timebase setting
The easiest way to change the timebase setting is with the TIMEBASETIMEBASETIMEBASETIMEBASE hotspot controls.

Click the up/down arrows to scroll through the timebase settings. The current timebase setting appears to the left of the 
up/down arrows. The strip chart updates as the timebase changes.  

You can also use a mouse wheel to change the timebase setting. Scroll the mouse wheel backward to decrease the 
timebase, or forward to increase the timebase. 

Hold down the Shift key to change the timebase setting in multiples of 10. For example, when you change the timebase 
while holding down the Shift key, the value changes from 1.00s to 10.0s, 100s, 1000s, etc.

Auto mode
When you enable Auto mode, the timebase value setting automatically increases when the strip chart acquires enough 
data to fill 50% of the screen for the next timebase setting scale. This is done in order to show all of the data points. 
You set the timebase to Auto mode by clicking on the AAAA  hotspot. 
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Using the Strip Chart Display Settings dialog to change the timebase setting
You can also change the timebase setting by selecting Display Settings from the Edit menu, and changing the Timebase 
option on the Strip Chart Display Settings dialog.
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